What are the system requirements? - Banana VPN


What are the system requirements?

Vpn accounts will work on computers running Windows 2000/XP/Vista/7 , Mac and Linux. Also works with iPhone, iPad, iTouch and Android 2.1+ devices and Nokia S60 with SymVPN

No additional software is required to use our service as we utilize the VPN software already in your operating system. Once you subscribe, we will send you all the information required to set up a connection. You may download our VPN dialler for windows if you prefer.